Forum Bug Reports and Feature Requests

Status
Not open for further replies.

Ripper

Зичу Вам успіхів
Joined
Nov 8, 2014
Messages
11,653
@Myrthos;

I was just trying to send a PM, but whenever I click preview or submit, I get this screen. Tried a few times.

Screenshot-2020-12-03-403-Forbidden.png
 
Joined
Nov 8, 2014
Messages
11,653

Myrthos

Cave Canem
Joined
Aug 30, 2006
Messages
11,212
You could PM me before, so what is different?
Using a different PC? Browser?
 
Joined
Aug 30, 2006
Messages
11,212

Ripper

Зичу Вам успіхів
Joined
Nov 8, 2014
Messages
11,653
You could PM me before, so what is different?
Using a different PC? Browser?

I had no problem PMing you before, and it's the same machine and browser I was using then. Only thing I can think of my end is that my VPN IP would have changed, and it's possible to get an abused IP that's been blacklisted by security systems. Odd that it would only affect sending a PM, but I'll trying changing addresses, and then another browser.
 
Joined
Nov 8, 2014
Messages
11,653

Ripper

Зичу Вам успіхів
Joined
Nov 8, 2014
Messages
11,653
@Myrthos;

Very curious. It was neither of those things. I wondered if it might be related to the character issue, so I went through removing one paragraph at a time, and then clicking preview. Turned out to be one line, unless removed, causes the error.

Seems to have sent fine now.
 
Joined
Nov 8, 2014
Messages
11,653

Redglyph

SasqWatch
Joined
Aug 29, 2020
Messages
5,678
Location
Good old Europe
@Myrthos;

Very curious. It was neither of those things. I wondered if it might be related to the character issue, so I went through removing one paragraph at a time, and then clicking preview. Turned out to be one line, unless removed, causes the error.

Seems to have sent fine now.

Let me guess, what was in that line? . . .

exploits_of_a_mom.png


Sorry for the Friday night geek humour :)
 
Joined
Aug 29, 2020
Messages
5,678
Location
Good old Europe

Myrthos

Cave Canem
Joined
Aug 30, 2006
Messages
11,212
@Myrthos;

Very curious. It was neither of those things. I wondered if it might be related to the character issue, so I went through removing one paragraph at a time, and then clicking preview. Turned out to be one line, unless removed, causes the error.

Seems to have sent fine now.
I think that might be a modsecurity issue. We have a different, more strict, configuration now.
Can you send me the text that caused the issue? Probably not by PM, as it wouldn’t work, but by mail.
 
Joined
Aug 30, 2006
Messages
11,212

Myrthos

Cave Canem
Joined
Aug 30, 2006
Messages
11,212
I would need to know what the message is that is given the problem.
RSS is fixed
 
Joined
Aug 30, 2006
Messages
11,212

vanedor

Keeper of the Watch
Joined
Nov 4, 2007
Messages
1,197
Location
Quebec city
Just a small feature idea (no clue how hard it would be to implement).

I really like the "News Watch" and "Forum Watch" feature on the front page. It really helps to know what's going on, what people are talking about. I just think it would be useful to add the date/time of the posts there. So we know it's not something We've already read. It seems especially useful to me for those thread where the same person comments a lot.
 
Joined
Nov 4, 2007
Messages
1,197
Location
Quebec city

Couchpotato

Burned Out Newsposter
Joined
Oct 1, 2010
Messages
29,798
Location
Spudlandia
Please allow us the option of deactivating alerts for mentions and quotes. Yeah it's trivial but there are members who quote and mention me I have no desire to reply to.:)
 
Joined
Oct 1, 2010
Messages
29,798
Location
Spudlandia

Strafe

Sentinel
Original Sin 2 Donor
Joined
Aug 17, 2008
Messages
335
I get the 404 error also when I try to respond to my PM, and yes, people I've already talked with trough PM's.
fgoJtX4.png
 
Joined
Aug 17, 2008
Messages
335

Myrthos

Cave Canem
Joined
Aug 30, 2006
Messages
11,212
Yeah I know. Don’t use the ampersand character. It is a character I know of that causes this. Perhaps there is another character as well. Look for the special ones.
 
Joined
Aug 30, 2006
Messages
11,212

Strafe

Sentinel
Original Sin 2 Donor
Joined
Aug 17, 2008
Messages
335
It could be words? I've deleted the last sentence and worked.
Thanks!
 
Joined
Aug 17, 2008
Messages
335

Myrthos

Cave Canem
Joined
Aug 30, 2006
Messages
11,212
It is something that is recognized by the firewall as a hacking attempt and it blocks. The age of the forum software doesn’t work too well with all those new security measures we have in place.
As mentioned elsewhere the solution is to move to completely new forum software, but we hacked quite a bit into these forums, so that will take some time.
 
Joined
Aug 30, 2006
Messages
11,212

Ripper

Зичу Вам успіхів
Joined
Nov 8, 2014
Messages
11,653
Yeah, I can imagine that the level of customisation of the Watch would be a chunk of work to replicate on a new platform. But I think old VBulletin 3 is starting to creak now. I'm sure some folks won't be happy with change, but I think it's the sensible thing to do, at this point.
 
Joined
Nov 8, 2014
Messages
11,653

bkrueger

Nothing to see here.
Joined
Dec 26, 2007
Messages
1,288
Probably it has been noted before, but the character coding in the page source sometimes doesn't fit to the actual encoding of the text.

The character encoding in the page source is charset=ISO-8859-1 (Western), but the text is in Unicode.

For example in this post https://www.rpgwatch.com/forums/showpost.php?p=1061631630&postcount=13381 I see something like "Yeah, I’ve thought …".

Edit: Is it possible that the post editor produces unicode but the overall page templates are made for Western?

When I switch to Unicode manually, I see the text correctly.
 
Joined
Dec 26, 2007
Messages
1,288
Status
Not open for further replies.
Top Bottom